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Lesson 13 Patterns and Weldments 
 

 
Figure 13.1 Mounting System Weldment  
 

OBJECTIVES 
 
 Create directional patterns and dimensional patterns 
 Pattern components on an assembly 
 Insert multiple standard parts using a reference pattern 
 Use fill to pattern a feature 
 Insert welds on a model 
 Utilize the Screw and Dowel Tools 

 

REFERENCES AND RESOURCES  
 

For Resources go to www.cad-resources.com > click on the PTC Creo Parametric 3.0 Book cover 
 

 Lesson Lecture  
 Book Projects PDF  
 Project Lectures 
 Quick Reference Card  
 Configuration Options  

 

Patterns and Weldments 
 
Creating a pattern is a quick way to reproduce a feature, or a component in an assembly (Fig. 13.1). A pattern 
is parametrically controlled. Therefore, you can modify a pattern by changing pattern parameters, such as the 
number of instances, spacing between instances, and original feature dimensions. Modifying patterns is more 
efficient than modifying individual features. In a pattern, when you change dimensions of the original feature, 
Creo Parametric 3.0 automatically updates the whole pattern. This lesson will introduce you to variations of 
the Pattern Tool, and introduce the Welding application. 
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Mounting Bracket 
 

For Lessons 13-18, step-by-step commands are sometimes limited to new software commands introduced or 
enhanced in that lesson. You are expected to do many of the modeling using commands and practices mastered 
from Lessons 1-12 without repeated detailed explanations. The Mounting Bracket will be the first component 
(Fig. 13.2). 
 

 
Figure 13.2 Mounting Bracket  
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Lesson 13 Steps 
 

Start a new part. Press: Ctrl+N > mounting_bracket > OK > File > Prepare > Model Properties > Units 

change >  > Close > Close >  > in the Graphics Window, press 

RMB > Define Internal Sketch > select datum FRONT > Sketch >  > sketch and dimension the L-shaped 

section [Fig. 13.3(a)] >  > modify the depth to 12 > Ctrl+D [Fig. 13.3(b)] >  >  > OK > change 
the color and make isometric the default model view 
 

  
Figure 13.3(a) Sketch the L-shaped Section  
 

  
Figure 13.3(b) Mounting Bracket will be 12.00 inches in Depth  
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Click:  >  >  >  > select datum FRONT > double-click in the Offset 

Translation field > 2.00 [Fig. 13.3(c)] > Enter > OK >  Resumes the previously paused tool >  > 

add the references and sketch and dimension the open section [Fig. 13.3(d)] > Ctrl+D >  > modify the rib 
thickness to 0.5 [Fig. 13.3(d)] > Enter [Fig. 13.3(e)] > Enter > Ctrl+S  
 

 
Figure 13.3(c) Offset Datum Plane (Note that you can also double-click on the value in the Graphics Window)  
 

 
Figure 13.3(d) Open Section for the Rib (Note the Reference Lines)   
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Figure 13.3(e) Rib Preview  
 

With the rib still selected, press: RMB > Pattern >  > Dimension > Dimensions tab > in the Graphics 

Window, select 2.00 > type 4.00 > Enter > left of 1 item(s), type 3 > Enter [Fig. 13.3(f)] >  > Ctrl+S  
 

 
Figure 13.3(f) Dimensional Pattern   
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Click:  > add the .500-13 hole per the Placement [Fis. 13.3(g)] and Shape requirements [Fig. 13.3(h)] 

>  > Ctrl+D > Ctrl+S  
 

 
Figure 13.3(g) 7.00 from Datum FRONT and 3.00 from Datum TOP  
 

 
Figure 13.3(h) Shape of .500-13 Hole   
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With the hole still selected (highlighted), press: RMB > Pattern >  > Fill > References tab > Define > 

select datum Right > click on the direction arrow to flip > Orientation Top > Sketch >  >  Offset > 

Loop > select the face (now facing you) > type -.3875 [Fig. 13.3(i)] >  [Fig. 13.3(j)] > Close >  > Sets 
the spacing between pattern member centers, type 1.00 > Enter > 

  
 

 
Figure 13.3(i) Offset -.3875  
 

  
Figure 13.3(j) Offset Loop   
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Click:  >  to toggle off the unwanted instances [Fig. 13.3(k)] > Ctrl+D >  [Fig. 13.3(l)] >   
 

 
Figure 13.3(k) Toggle Off Unwanted Instances of the Pattern  
 

 
Figure 13.3(l) Pattern Preview   
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Click: View tab  >  all off > Applications tab > LMB in the Graphics 

Window >  >  >  > Location 
tab > select the surface as Side 1 [Fig. 13.4(a)] > press RMB > Side 2  
 

 
Figure 13.4(a) Select Side 1 of the Weld Set 1   
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Press and hold the Ctrl key and select the vertical surfaces of the ribs > release the Ctrl key > RMB > New 
Set [Fig. 13.4(b)] 
 

 
Figure 13.4(b) Select the (nine) Vertical Surfaces for Side 2 of the Weld Set 1   
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Press: RMB > Side 1 > select the vertical surface as Side 1 [Fig. 13.4(c)] > press RMB > Side 2  
 

 
Figure 13.4(c) Select Side 1 of the Weld Set 2   
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Press and hold the Ctrl key and select the surfaces of the ribs > release the Ctrl key >  on [Fig. 13.4(d)] > 

 >   
 

If you select the wrong item, select the appropriate Set # > select the appropriate Details button > place the 
pointer over the item in the appropriate dialog box > RMB > Remove > Ctrl key > select another surface.  
 

 
Figure 13.4(d) Select the (nine) Surfaces for Side 2 of the Weld Set 2   
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Click:  [Fig. 13.4(e)] > LMB to deselect >  (from the Welding Ribbon) > File > Manage File > 

Delete Old Versions > Yes >  Close  
 

 
Figure 13.4(e) Completed Fillet Weld 
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Base Plate 
 

 
Figure 13.5(a) Base Plate  
 

  
Figure 13.5(b) Base Plate Detail   
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Base Plate dimensions [Figs. 13.5(a-b)]. Press: Ctrl+N > type base_plate > OK > File > Options > Customize 
Ribbon > Import/Export > Import customization file > select your previously saved .ui file from Lesson 2 

( ) > Open > Import Mode Customizations > Configuration Editor > 
Import/Export > Import configuration file > select your previously saved file from Lesson 2 

(CREO_textbook.pro) > Open > OK > No > View tab >   all on > 

select datum TOP > Model tab >  >  >  > sketch and dimension the 

rectangular section [Fig. 13.5(c)] > spin the part >  > modify the depth to 1.50 inches [Fig. 13.5(d)] > 
Enter > in the Graphics Window, MMB > LMB to deselect > Ctrl+D > Ctrl+S > OK  
 

  
Figure 13.5(c) Sketch the Rectangular-shaped Section  
 

 
Figure 13.5(d) Depth of 1.50   
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Click:  > create the hole as per the Placement and Shape requirements [Figs. 13.5(e-g)] > 

 >  > 

Ctrl+D >  Save 
 

 
Figure 13.5(e) 1.00 Diameter Hole  
 

                      
Figure 13.5(f) Hole Placement                                          Figure 13.5(g) Hole Shape   
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With the hole still selected, press: RMB > Pattern [Fig. 13.5(h)] >  > Direction > select two reference 

direction surfaces [Fig. 13.5(i)] >  > Annotate tab > in the Model Tree, expand the Pattern > select the 

Extrude, Pattern and Hole features > Show Annotations >  tab >  > OK > move the dimensions as 
needed  
 

 
Figure 13.5(h) Pattern  
 

 
Figure 13.5(i) Pattern Preview  
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Click: LMB to deselect > select the 1.00 diameter dimension > press RMB > Properties > Display tab > 

 [Fig. 13.5(j)] > Move > pick a new position > OK [Fig. 13.5(k)] > LMB to deselect > Model 
tab > Ctrl+D > Ctrl+S > File > Close  
 

 
Figure 13.5(j) Dimension Properties, Display Tab  
 

 
Figure 13.5(k) Edited Dimension Note (Your Note Orientation May Be Different)   
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Mounting System Assembly 
 

 
Figure 13.6(a) Mounting System Assembly  
 

 
Figure 13.6(b) Mounting System Assembly Exploded  
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Figure 13.6(c) Mounting System Assembly Component Placement Location Dimensions  
 

 
Figure 13.6(d) Mounting System Assembly Component Placement Location in the Assembly Model  
 
Create the Mounting System Assembly shown in Figures 13.6(a-d).  
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Click:  >  > mounting_system > OK >  off >  > base_plate > Open > 

press RMB > Default Constraint >  >  > mounting_bracket > Preview > Open > use the 
3D Dragger to initially orient and position the component > Placement tab > first constraint [Fig. 13.7(a)]  
 

  
Figure 13.7(a) First Constraint Distance Offset 1.50 (Enter a Negative Value if Required)   
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In the Graphics Window, press: RMB > New Constraint > second constraint [Fig. 13.7(b)]  
 

 
Figure 13.7(b) Distance Offset 3.00 (Enter a Negative Value if Required)   
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Select: New Constraint in the Placement window > [Fig. 13.7(c)] >  >  > OK  
 

 
Figure 13.7(c) Coincident (Use the RMB and click through the features and select the bottom face of the Mounting Bracket)  
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Set:  >  > pick a position on front corner of the Mounting_bracket [Fig. 
13.8(a)] > locate the hole at .750 from each vertical face [Fig. 13.8(a)] > OK > Ctrl+S 
 

 
Figure 13.8(a) Point 
 

 
Figure 13.8(b) Point Position 



Creo Parametric 3.0  Lesson 13 

©	2014	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 607

 

With the point still selected:  [Fig. 13.8(c)] > press Ctrl key > select the surface [Fig. 13.8(d)] > OK 
> LMB > Ctrl+S 
 

 
Figure 13.8(c) Select the Point 
 

 
Figure 13.8(d) Select the Surface 
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Select Tools tab >  Screw >  > Select the position (point/axis) APTN0 >   
[Fig. 13.9(a)] > Select the screw head placement surface [Fig. 13.9(b)]  
 

 
Figure 13.9(a) Select the Point 
 

 
Figure 13.9(b) Select the Surface 
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Select the nut or the thread surface start surface [Fig. 13.9(c)] > Set Screw Fastener Definition [Fig. 13.9(d)  
 

 
Figure 13.9(c) Select the Thread Start Surface 
 

 
Figure 13.9(d) Screw Fastener Definition  
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Click: OK [Fig. 13.9(e)] > LMB >  Save  
 

In the Model Tree and graphics window note the features automatically generated on the parts and in 
the assembly. 
 

 
Figure 13.9(e) Holes, Threads, Screw and Washer  
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Select the point, axes, and Group SL_Screw from the Model Tree > RMB > Group > Group [Fig. 13.10(a)] 

> RMB > Pattern [Fig. 13.10(b)] >  > LMB 
 

 
Figure 13.10(a) Group  
 

 
Figure 13.10(b) Pattern  
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Select:  of the Mounting Bracket in the Model Tree > RMB > Pattern > Reference >  > 

select  of the Base Plate in the Model Tree > RMB > Pattern [Fig. 13.10(c)] >  > LMB > 
Ctrl+S   
 

 
Figure 13.10(c) Pattern  
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Select: Base_Plate from the Model Tree > spin the model > RMB > Activate > View tab > RMB on the 
model color > Edit > RMB > make the Transparency about 27% [Fig. 13.10(d)] > Close > Ctrl+D > select 
Mounting_System.asm from the Model Tree > RMB > Atctivate > LMB > Ctrl+S 
 

 
Figure 13.10(d) Transparency   
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Select: MOUNTING_BRACKET and the Pattern 1 of LOCAL_GROUP from the Model Tree > RMB > 

Group > Group [Fig. 13.11(a)] >  >  >  > 

 > OK > Direction Reference Surf.F5 [Fig. 13.11(b)] 
 

 
Figure 13.11(a) Group the Mounting_Bracket and Pattern 1 of Local_Group  
 

 
Figure 13.11(b) Copy > Paste Special > Select the Surface  
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Drag the Group 22 inches [Fig. 13.11(c)] >  > LMB [Fig. 13.11(d)] > Ctrl+S    
 

 
Figure 13.11(c) Drag the Group 
 

 
Figure 13.11(d) Assembly  
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Select: Base_Plate > RMB > Activate >  >  > select the DATUM AXIS [Fig. 

13.12(a)] >  

> Ctrl key > select the top surface of the Base_Plate [Fig. 13.12(b)] >   
 

 
Figure 13.12(a) Select the Axis  
 

 
Figure 13.12(b) Threaded Hole  



Creo Parametric 3.0  Lesson 13 

©	2014	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 617

 

With the threaded hole still selected > RMB > Pattern > Reference [Fig. 13.13(a)] >  > select 

Mounting_System.asm from the Model Tree > RMB > Atctivate > LMB >  [Fig. 13.13(b)]  
 

 
Figure 13.13(a) Pattern 
 

  
Figure 13.13(b) Patterned Threaded Hole  
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With the assembly active:  Saved Orientations > Front > zoom in > Tools tab >  > 

 >  > pick a position on front corner of the Base_Plate > locate the hole from each 

vertical face/surface [Fig. 13.14(a)] > with the point still selected:  > press Ctrl key > select the surface 
[Fig. 13.14(b)] > OK > LMB > Ctrl+S 
 

 
Figure 13.14(a) Datum Point 
 

 
Figure 13.14(b) Datum Axis 
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Select Tools tab >  Dowel >  > Select the position (point/axis) APTN16 >   
> Select the dowel pin placement surface [Fig. 13.15(a)] > OK > Set the Dowel Pin Fastener Definition 
[Fig.13.15(b)] > OK > Ctrl+S  
 

 
Figure 13.15(a) Point and Surface Selection for Dowel Placement 
 

 
Figure 13.15(b) Dowel Pin Fastener Definition 



Creo Parametric 3.0  Lesson 13 

©	2014	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 620

 

Select the new features and create a group > Model tab > Pattern Fig.13.16(b)] >  > Ctrl+S  
 

 
Figure 13.16(a) Group 
 

 
Figure 13.16(b) Group Pattern (2 of 4 positions) 
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Select: SL_ID_1798 from the Base_Plate in the Model Tree > RMB > Pattern > Reference Fig.13.17(a)] 

>  > Ctrl+S Fig.13.17(b)] 
 

 
Figure 13.17(a) Pattern the Hole 
 

 
Figure 13.17(a) Dowels  
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Click: Reference Viewer >  >  (Fig. 13.18) > Close >  
 

 
Figure 13.18 Reference Viewer  
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Click: View tab > Model Display Group > Temporary Shade (Fig. 13.19) 
 

  
Figure 13.19 Temporary Shading  
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Ctrl+N > Drawing > mounting_system > Template Browse > from Lesson 12 select ASM_FORMAT_E > 
OK > delete the top view > SCALE .5 > add a Projection View from the Front view > RMB > Sheet Setup 
> Browse > E Size > OK [Fig. 13.20(a)] > add a New Sheet and General View > SCALE .75 [Fig. 13.20(a)] 
 

 
Figure 13.20(a) Sheet 1 
 

 
Figure 13.20(b) Sheet 1 
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Double click on the view: Angles > Edge/Axis > select a vertical reference > 180 [Fig. 13.21(a)]  
 

 
Figure 13.21(a) Reorient the Model 
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Click: Apply [Fig. 13.21(b)] > OK > Ctrl+S 
 

 
Figure 13.21(a) Reoriented View  
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Ctrl+S > File > Manage File > Delete Old Versions > Enter > File > Save As > Type  > Zip File (*.zip) 
[Fig. 13.22(a)] (The Zipped file includes all components, the assembly, and the drawing.) > OK > upload the 
zip file to your course interface or attach to an email and send to your instructor and/or yourself [Fig. 13.22(b)] 
> File > Close > File > Exit >Yes 
 

 
Figure 13.22(a) Zip File 
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Figure 13.22(a) Zipped file includes all components, the assembly, and the drawing 
 

For additional projects, see www.cad-resources.com > click on the image of your book cover.  


