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Lesson 15 Sweeps 
 

   
Figure 15.1 Bracket 
 
OBJECTIVES 
 

 Create a constant-section sweep feature  
 Sketch a Trajectory for a sweep  
 Sketch and locate a Sweep section  
 Understand the difference between adding and not adding Inner Faces  
 Be able to Edit a sweep 

 
REFERENCES AND RESOURCES  
 

For Resources go to www.cad-resources.com > click on the PTC Creo Parametric 3.0 Book cover 
 

 Lesson Lecture  
 Book Projects PDF  
 Project Lectures 
 Quick Reference Card  
 Configuration Options  

 

SWEEPS 
 

A Sweep is created by sketching or selecting a trajectory and then sketching a section to follow along it. The 
Bracket, shown in Figure 15.1, uses a simple sweep in its design. A constant-section sweep (Fig. 15.2) can use 
either trajectory geometry sketched at the time of feature creation or a trajectory made up of selected datum 
curves or edges. The trajectory [Figs. 15.3 (a-c)] must have adjacent reference surfaces or be planar. When 
defining a sweep, Creo Parametric 3.0 checks the specified trajectory for validity and establishes normal 
surfaces.  
 

 
Figure 15.2 Sweep Forms  
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Figures 15.3(a-c) Sweep Trajectory and Section  
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Lesson 15 STEPS 
 

 
Figure 15.4 Bracket Detail 
 
Bracket 
 
The Bracket (Fig. 15.4) requires the use of the Sweep command. The T-shaped section is swept along the 
sketched trajectory.  
 
Start a new part. Press: Ctrl+N > Name bracket > Enter > File > Prepare > Model Properties  
 
 Material = al6061.mtl 
 Units = Inch lbm Second 
 

Set Datum  and Rename the default datum planes and coordinate system:  
 Datum TOP = C 
 Datum FRONT = A 
 Datum RIGHT = B 
 Coordinate System = CSYS_SWEEP 
 

In the Model Tree, click on BRACKET.PRT > RMB > Info > Model [Fig. 15.5(a)] >  close the browser 
panel > in the Graphics Window, LMB to deselect  
 
Color: set the model color as desired [Fig. 15.5(b)]  
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Figure 15.5(a) Bracket Information (your Browser Window information may appear differently)  
 

  
Figure 15.5(b) Bracket Color (your display may appear differently) 
 

The extrusions on both sides of the swept feature are to be created with the dimensions shown in 
Figures 15.6(a-j). 
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Figure 15.6(a) Bracket Drawing, Front View 
 

 
Figure 15.6(b) Bracket Drawing, Top View 
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Figure 15.6(c) Bracket Drawing, Right Side View 
 

 
Figure 15.6(d) Bracket Drawing, Left Side View 
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Figure 15.6(e) SECTION A-A                                                                             Figure 15.6(f) Swept Arm 
 

      
Figure 15.6(g) SECTION B-B                                                            Figure 15.6(h) Cut 
 

      
Figure 15.6(i) SECTION C-C                                                             Figure 15.6(j) Counterbore Hole 
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Start by modeling the first feature [Fig. 15.7(a)], it will be used to establish the sweep’s position in space. 
Sketch the extrusion on datum A (FRONT) [Fig. 15.7(b)] and centered on B (RIGHT) and C (TOP). After 
having SET Datum Tag annotations and renaming the default datum planes: pick datum B from the Model 
Tree > RMB > Properties > Text Style > Height 0.15625 > Enter > Apply > OK > OK > repeat for datum 
C and datum A > Ctrl+D > in the Graphics Window, LMB to deselect > Ctrl+S > OK 

 

  
Figure 15.7(a) Bracket’s First Section 
 

  
Figure 15.7(b) Completed Extrusion 
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Click:  >  >  Sketch > select datum B as the sketching plane [Fig. 15.8(a)] > Orientation 

Top > Sketch >  > in the Graphics Window, press RMB > References > in the References 
dialog box, delete datums A and C and add the front and top faces of the first extrusion [Fig. 15.8(b)] > Solve 
> Close  

 

  
Figure 15.8(a) Select Datum B as the Trajectory Sketching Plane, Orientation is Top  
 

  
Figure 15.8(b) Delete Datums A and C and add the Front and Top Surfaces as References   
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Sketch [Fig. 15.8(c)], add fillets, dimension, and modify the trajectory [Fig. 15.8(d)] >   
 

  
Figure 15.8(c) Sketch the Three Lines. Start the trajectory by sketching a horizontal line from this position. 
 

  
Figure 15.8(d) Completed Sketch   
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Press: MMB to spin the model >  Resumes the previously paused tool [Figs. 15.8(e-f)]  
 

  
Figure 15.8(e) Resumes the previously paused tool 

 

  
Figure 15.8(f) Trajectory   
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Click:  Create or edit sweep section >  >  > Profiles tab [Fig. 15.9(a)] > double-

click on  > move the pointer away from the model > LMB to place the section [Fig. 15.9(b)] > 

 No Hidden  
 

  
Figure 15.9(a) Sketcher Palette 

 

  
Figure 15.9(b) Place the Section   
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Place the pointer on the position handle [Fig. 15.9(c)] > press and hold down the RMB > move the position 
handle [Fig. 15.9(d)] (Note the Midpoint constraint) > drop the handle (release the RMB) in the new position 
[Fig. 15.9(e)] > place the pointer on the rotate handle [Fig. 15.9(f)] > press and hold down the LMB > move 
the pointer to rotate the section 90 degrees [Fig. 15.9(g)] > drop the handle (release the LMB) in the new 
position [Fig. 15.9(h)] > place the pointer on the position handle [Fig. 15.9(i)] > press and hold down the LMB 
> move the section to the start point of the trajectory [Fig. 15.9(j)] > drop the section in the new position [Fig. 

15.9(k)] >  from the Rotate Resize ribbon > Close the Sketcher Palette dialog box  
 

    
Figure 15.9(c) RMB on Move Handle            Figure 15.9(d) Move the Handle     Figure 15.9(e) Drop the Handle 
 

    
Figure 15.9(f) LMB on Rotate Handle     Figure 15.9(g) Rotate 90 Degrees         Figure 15.9(h) Rotated Section  
 

        
Figure 15.9(i) LMB on Move Handle       Figure 15.9(j) Place the Section              Figure 15.9(k) Drop Section 
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Add eight fillets > add constraints and dimensions [Fig. 15.9(l)] > using the dimensions of the detail drawing 

[Fig. 15.9(m)], modify the section [Fig. 15.9(n)] >  > press MMB to spin the part  

 

  
Figure 15.9(l) Add Eight Fillets, Constraints, and the Dimensioning Scheme  
 

    
Figure 15.9(m) Section AA from Detail Drawing              Figure 15.9(n) Modified Sketch   
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Click:  Shading with Edges > Ctrl+D [Fig. 15.9(o)] >  [Fig. 15.9(p)] >  Save 
 

  
Figure 15.9(o) Shaded Sweep Preview  
 

  
Figure 15.9(p) Completed Sweep  
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Add the next extrusion (8.00 by .875) [Figs. 15.10(a-b)] > model the cut feature (6.76 by .250 deep) [Figs. 
15.10(c-d)]  
 

           
Figure 15.10(a) 8.00 Diameter                                                                             Figure 15.10(b) .875 Thickness  
 

    
Figure 15.10(c) 6.76 Diameter                                                                         Figure 15.10(d) .250 Cut   
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Add chamfers (45 X .125) [Fig. 15.10(e)] > Ctrl+D > Ctrl+S > the next feature will be the slot [Fig. 
15.11(a)]  
 

  
Figure 15.10(e) Chamfer  
 

 
Figure 15.11(a) Patterned Slot   
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Click:  Extrude >  Remove Material > select the cut face as the Sketch Plane [Fig. 15.11(b)] > 

 >  > delete F2(C) >  (in the References dialog box) > add axis A_1 [Fig. 
15.11(c)] > Solve > Close  
 

  
Figure 15.11(b) Sketch Plane 
 

  
Figure 15.11(c) Sketch References   
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Add a sketcher point at the center of the round extrusion, click:  [Fig. 15.11(d)] > MMB > File > 

Options > Sketcher >  > OK > No > Setup Group >  >  >  > 

Radial Spacing .50 > Enter > Origin  [Fig. 15.11(e)] > select the construction point > OK > 

 [Fig. 15.11(f)]  
 

          
Figure 15.11(d) Add a Construction Point                                Figure 15.11(e) Grid Settings Dialog Box  
 

  
Figure 15.11(f) Polar Grid 
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In the Graphics Window, press: RMB > Construction Centerline > add a vertical and two angled centerlines 
> in the Graphics Window, MMB > LMB to deselect > press RMB > Circle > sketch a circle > in the Graphics 

Window, MMB to end the current tool > press RMB > Construction [Fig. 15.11(g)] > next to , click:  

flyout >  Center and Ends > sketch four arcs > MMB > File > Options > Sketcher >  > 
OK > No > add dimensions, constraints, and modify dimension values [Fig. 15.11(h)]  
 

   
Figure 15.11(g) Change the Circle into a Construction Circle 
 

  
Figure 15.11(h) 0.51625 X 60-Degree Slot on a 4.50 Diameter Bolt Circle  
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Click: Ctrl+D >  Shading with Edges >  > in the Graphics Window, place the pointer on  > press 

RMB [Fig. 15.11(i)] > To Selected > select the (back) surface of the circular extrusion [Fig. 15.11(j)] >  

[Fig. 15.11(k)] >   
 

  
Figure 15.11(i) To Selected  
 

  
Figure 15.11(j) Select Back Surface of the Circular Extrusion  
 

  
Figure 15.11(k) Slot  
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With the slot still selected, press: RMB > Pattern [Fig. 15.12(a)] >  >  > select A_1 >  > 

Enter>  > Enter [Fig. 15.12(b)] >  [Fig. 15.12(c)] >  > LMB to deselect  
 

  
Figure 15.12(a) Press RMB > Pattern 
 

  
Figure 15.12(b) Pattern the Slot Using the Axis   
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Figure 15.12(c) Completed Pattern  
 
Model the face cut and then create and pattern the counterbore holes [Figs. 15.13(a-b)]  
 

      
Figures 15.13(a-b) Create the Face Cut and Pattern Counterbore Holes   
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Click:  Extrude >  Remove Material > select the surface > Setup Group > Display > 

 off >  Offset > Loop > select the surface > with the arrow pointing outward, type: -
.125 [Fig. 15.13(c)] > Enter > Close > if your value is rounded: select the .13 dimension > press RMB > 

 (uncheck) [Fig. 15.13(d)] > LMB to deselect  
 

 

  
Figure 15.13(c) Use Offset Loop -.125 (if the arrow points inward, enter .125)  
 

  
Figure 15.13(d) Select the Dimension > Press RMB > Uncheck Round Display Value   



Creo Parametric 3.0  Lesson 15 

©	2013	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 675

 

Click:  > for the depth, type: .125 > Enter [Fig. 15.13(e)] >  > in the Graphics Window, LMB to 
deselect [Fig. 15.13(f)] > Ctrl+S > OK  
 

  
Figure 15.13(e) Cut Preview 
 

  
Figure 15.13(f) Completed Cut   
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Click: Ctrl+D > model the hole using the detail dimensions [Fig. 15.14(a)] >  Hole > Placement tab 
> place the hole per Placement requirements [Fig. 15.14(b)]  
 

 
Figure 15.14(a) Counterbore Hole Detail  
 

 
 Figure 15.14(b) Hole Placement   
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Click: Shape tab > shape the hole per Shape requirements [Fig. 15.14(c)] >  > in the Graphics Window, 

press RMB > Pattern >  > Dimension > select for Direction 1 2.50 > Enter > Dimensions tab > pick Click 
here to in the Direction 2 field > select for Direction 2 1.50 > Enter > modify Increment 2.50 to -5.00 > Enter 
> modify Increment 1.50 to -3.00 > Enter [Fig. 15.15(a)]  
 

  
Figure 15.14(c) Hole Shape  
 

  
Figure 15.15(a) Pattern Dimensions  



Creo Parametric 3.0  Lesson 15 

©	2013	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 678

 

Click:  > in the Graphics Window, press RMB > Edit [Fig. 15.15(b)] > LMB > View tab > 

 off >  off > press the Ctrl key > select Datums A, B, and C from the 
Model Tree > RMB > Hide [Fig. 15.16(a)]  
 

  
Figure 15.15(b) Pattern Dimensions  
 

  
Figure 15.16(a) Hide the Datum Planes and the Sketch   
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Click: File > Options > Model Display > set as shown [Fig. 15.16(b)]  
 

  
Figure 15.16(b) Model Display Options (Note: A shade quality of 50 will greatly increase your Models’ file size) 
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Click: Entity Display > set as shown [Fig. 15.16(c)]  
 

  
Figure 15.16(c) Entity Display Options   
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Click: Environment > set as shown [Fig. 15.16(d)] > OK > No >  Shading with Reflections [Fig. 
15.16(e)] > View tab > Model Display > Temporary Shade > Ctrl+D > Ctrl+S  
 

  
Figure 15.16(d) Environment Options (your Working directory may be different)  
 

  
Figure 15.16(e) Shading With Reflections (the quality of your graphics card and graphics settings may prevent this display)  
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Click: Render tab > Scene > Lights tab > OK (if needed) >  Add new spotlight > Name  Color 
for lighting > adjust the slide bars in the Color Editor to the RGB values provided [Fig. 15.17(a)] > OK 
(from the Color Editor dialog box)  
 

 
Figure 15.17(a) Light Setup 
 

Click:  on > Ctrl+R > Move the light from its default position to the other side of the model. Place the 
pointer on the circle behind the light (highlights) [Fig. 15.17(b)] > press and hold down the LMB > move the 

pointer to the other side of the model > release the LMB [Fig. 15.17(c)] > Close (the Scenes dialog box) >  
off > Ctrl+S > Enter > File > Close  
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Figure 15.17(b) Move the Light (experiment with different positions) 
 

 
Figure 15.17(c) New Light Position (experiment with different positions) 
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Press: Ctrl+N >  > Name bracket > OK > OK > detail the part as per ASME Y14.5 using 
multiple views and sheets as you see fit (Fig. 15.18) > Ctrl+S > OK > File > Manage File > Delete Old 

Versions > Enter > File > Save As > Type  > Zip File (*.zip) > OK > upload the zip file to your course 
interface or attach to an email and send to your instructor and/or yourself > File > Close > File > Exit > Yes  
 

 
Figure 15.18 Possible Detail Views and Dimensioning Scheme  
 

Download additional projects from www.cad-resources.com.  


