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Lesson 16 Helical Sweeps and Annotations 
 

 
Figure 16.1 Helical Compression Spring Drawing 
 

OBJECTIVES 
 

 Create a helical compression spring with a Helical Sweep 
 Use sweeps to create hooks on extension springs 
 Create plain ground or hook ends on a spring 
 Create 3D Notes and Annotation Features 

 

REFERENCES AND RESOURCES  
 

For Resources go to www.cad-resources.com > click on the PTC Creo Parametric 3.0 Book cover 
 

 Lesson Lecture  
 Book Projects PDF  
 Project Lectures 
 Quick Reference Card  
 Configuration Options  

 

Helical Sweeps and Annotations 
 
A helical sweep (Fig. 16.1) is created by sweeping a section along a helical trajectory. The trajectory is defined 
by both the profile of the surface of revolution (which defines the distance from the section origin of the helical 
feature to its axis of revolution) and the pitch (the distance between coils). The trajectory and the surface of 
revolution are construction tools and do not appear in the resulting geometry.  

Annotation features are data features that you can use to manage the model annotation including surface 
finish, geometric tolerances, notes, and so on. Model notes are pieces of text, which can contain links (URL’s) 
to World Wide Web pages, which you can attach to objects in Creo. Model notes, increase the amount of 
information that you can attach to any entity in your model.  
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Helical Sweeps 
 
The Helical Sweep command is available 
(Fig. 16.2) for both solid and surface features. 
You can define the helical sweep feature using 
the following options: 

 
 Keep constant section The pitch is 

constant 
 Vary section The pitch is variable 

and defined by a graph 
 Thru axis of revolution The section 

lies in a plane that passes through the 
axis of revolution 

 Normal To trajectory The section is 
oriented normal to the trajectory 

 Normal to projection The section is 
oriented normal to the projection 

 Use right handed rule The trajectory 
is defined by the right-hand rule 

 Use left handed rule The trajectory 
is defined by the left-hand rule 

                                                                                          
 

 Figure 16.2 Helical Sweeps 
 

Annotations 
 
Model notes are text strings, which can be placed flat to the screen (view plane) in model space (Fig. 16.3). 
Note(s) can be attached to any entity in your model. When you attach a note to an entity, that entity is 
considered the parent of the note. If you delete the parent entity, all child note(s) are deleted with it. You can 
also allocate a URL to each model note. You can use model notes to communicate with members of your 
workgroup as to how to review or use a model, explain how you approached or solved a design problem when 
modeling, and explain changes that you have made to the features of a model over time. 

Annotation features can also be notes, but also include: symbols, surface finish, geometric tolerance, set 
datum tags, ordinate baseline dimensions, driven dimension, and so on. 
 

  
Figure 16.3 Model Notes 
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Lesson 16 STEPS 
 

 
Figure 16.4(a) Helical Compression Spring with Datum Planes and Model Note 
 
Helical Compression Spring 
 
Springs [Fig. 16.4(a)] and other helical features are created with the Helical Sweep command. A helical sweep 
is created by sweeping a section along a trajectory that lies in the surface of revolution: The trajectory is 
defined by both the profile of the surface of revolution and the distance between coils. The model for this 
lesson is a constant-pitch right-handed helical compression spring with ground ends, a pitch of 40 mm, and a 
wire diameter of 15 mm [Figs. 16.4(b-e)]. 
 

 
Figure 16.4(b) Helical Compression Spring Drawing: DETAIL A 
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Figure 16.4(c) Helical Compression Spring Drawing, Section 
 

                 
Figure 16.4(d) FREE LENGTH 240                                                                   Figure 16.4(e) 3D Model Note 
 

Start a new part. Click:  Create a new model >  > Name helical_compression_spring > 

 > OK > File > Prepare > Model Properties (set the material and units): 
 

 Material = ss.mtl 
 Units = millimeter Newton Second 
 

Set Datum  and Rename the default datum planes and coordinate system: 
 

 Datum TOP = A 
 Datum FRONT = B 
 Datum RIGHT = C 
 Coordinate System = CSO 
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Click:  >  >  Helical Sweep > References tab > Define [Fig. 16.5(a)] > select 

datum B > Sketch >  > RMB > Axis of Revolution > add a vertical centerline along datum C > MMB > 
RMB > Line Chain > starting on the edge of datum create the angled line > MMB > MMB [Fig. 16.5(b)]  

 

 
Figures 16.5(a) Helical Sweep Tool 
 

 
Figure 16.5(b) Helix Sweep Profile Sketch. Note the Start Arrow Direction. 
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Press: RMB > Dimension > add the height (free length) dimension > MMB > MMB [Fig. 16.5(c)] > window-

in the dimensions > press RMB > Modify change the values to the design sizes [Fig. 16.5(d)] >   
 

 
Figure 16.5(c) Dimensioned Sketch  
 

 
Figure 16.5(d) Modified Dimensions  
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Enter the pitch value 40  > Enter [Fig. 16.5(e)] >  Create or edit sweep section from the 

Dashboard >  Sketch View >  Center and Point sketch the section geometry of the spring at the 
intersection of the crosshairs [Fig. 16.5(f)] > MMB > LMB > select the dimension > press RMB > Modify > 
type 15 > Enter > OK > LMB [Fig. 16.5(g)]  

 

    
Figure 16.5(e) Pitch 24, change to 40  
 

     
Figure 16.5(f) Sketch a Circle                                                    Figure 16.5(g) Wire Diameter 15   
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Click: RMB > OK [Fig. 16.5(h)] > RMB > Show Section Dimensions > Ctrl+D >  > View tab > 
Appearance Gallery > change the color of the part > Ctrl+S > OK [Fig. 16.5(i)] > change your model color 
 

 
Figure 16.5(h) Helix Preview  
 

 
Figure 16.5(i) Completed Helical Sweep  
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Create the ground ends, click: Model tab >  >  expand depth options by opening slide-up 

panel >  Extrude on both sides >  Remove Material > in the Graphics Window, press RMB > Define 
Internal Sketch > Sketch Plane- pick datum C > Reference- pick datum A > Orientation- Bottom [Fig. 

16.6(a)] > Sketch >  > RMB > Line Chain > draw a horizontal line > MMB > MMB > LMB > modify 

the dimension [Fig. 16.6(b)] > spin the model as needed >   
 

  
Figure 16.6(a) Cut Sketch Orientation  
 

 
Figure 16.6(b) Creating Ground Ends (any length will work as long as it goes beyond the spring)  
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Extend a depth handle to 300 so as to include the full spring > in the Graphics Window, press RMB > Flip 

Material Side [Fig. 16.6(c)] >  [Fig. 16.6(d)] > LMB  
 

 
Figure 16.6(c) Depth Handles (Squares) and Material Side Arrow (currently pointing upward)  
 

 
Figure 16.6(d) Completed Cut for One Ground End  
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The second ground end is created using similar commands [Fig. 16.7(a)]. > Complete the spring [Fig. 16.7(b)]. 
> Ctrl+D > Ctrl+S  
 

 
Figure 16.7(a) Creating the Second Ground End  
 

  
Figure 16.7(b) Preview of the Completed Cut for the Second Ground End  
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Figure 16.8 provides an ECO (Engineering Change Order) for a new spring. Copy the file you are working on 
by clicking: File > Save As > Save a Copy > HELICAL_EXTENSION_SPRING > OK > File > Close > 
File > Open > helical_extension_spring.prt > Open > delete the existing ground ends > modify the pitch to 
10 mm > change the wire diameter to 7.5 mm > complete the extension spring [Figs. 16.9(a) through 16.10(d)]. 
The free length is to be 120 mm. The large diameter will now be 180 mm, and the small diameter will be 120 
mm. > Ctrl+S > OK > File > Close  

 

 
Figure 16.8 ECO to Create a Helical Extension Spring [You are not creating this ECO drawing; you are making a new part 
from an existing part (copied) using different dimensions and features]  
 

 
Figure 16.9(a) Ground End 
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Figure 16.9(b) Detail Drawing of Helical Extension Spring with Machine Hook Ends 
 

 
Figure 16.9(c) Front View 



Creo Parametric 3.0  Lesson 16 

©	2014	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 698

 

 
Figure 16.9(d) Top View 
 

                      
Figure 16.9(e) Right Side View                                                                Figure 16.9(f) Left Side View 
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Create the machine hooks using simple sweeps and cuts, as shown in Figures 16.10(a) through 16.10(d).  

 

                             
Figure 16.10(a) Sweep R30                                                          Figure 16.10(b) Completed Sweep 
 

 
Figure 16.10(c) Small Hook End Sweep 
 

 
Figure 16.10(d) Large Hook End Sweep 
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Annotations 
 
When you attach a note to an entity, that entity is considered the “parent” of the note. Deleting the parent 
deletes all of the notes of the parent. You can attach model notes anywhere in the model; they do not have to 
be attached to a parent. Here we will add a note to the part and describe the spring. 
 
Click: File > Open > helical_compression_spring.prt > Open > Annotate tab > FLAT TO SCREEN > 

RMB on the command button > Set >  Unattached Note [Fig. 16.11(a)] > select a place on the 
screen to place the note > type the following note [Fig. 16.11(b)]: 
 

Helical Compression Spring 
Constant Pitch 
Right-Handed 
40 mm Pitch 
Wire Diameter 15mm 
Ground Ends 
(grind ends parallel) 

 

 

  
Figure 16.11(a) 3D Notes                                                                                     Figure 16.11(b) Note Dialog Box 
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Click: MMB [Fig. 16.11(c)] > move the note as needed > with the note still selected (highlighted); RMB > 

Text Style >  > Height 4 > Enter [Fig. 16.11(d)] > OK > LMB > Ctrl+S  
 

 
Figure 16.11(c) Placing the Note 
 

 
Figure 16.11(d) Completed Note 
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You can toggle model annotations on and off using  Turn on or off 3D annotations and annotation 
elements > toggle the annotations off and on > display the note in the Model Tree by clicking: 

 >  > toggle all on [Fig. 16.12(a)] > Apply > OK [Fig. 16.12(b)]  
 

            
Figure 16.12(a) Displaying 3D Notes (Annotations) in Model Tree       Figure 16.12(b) Detail Tree and Model Tree 
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Click on  in the Model Tree > RMB > Rename > type: Compression_Spring > Enter > RMB > 
Add Link [Fig. 16.13(a)] > type: http://www.americanprecspring.com/ [Fig. 16.13(b)] > OK > OK > LMB 
> place your pointer over the note in the graphics area to see the Screen Tip [Fig. 16.13(c)]  
 

 
Figure 16.13(a) Press RMB > Properties (your options list may appear differently)  
 

                         
Figure 16.13(b) Hyperlink                                                                          Figure 16.13(c) Screen Tip                                                                 
 

Create a screen tip that will display as the pointer passes over the note, click:  > type SPRING 
COMPANY [Fig. 16.13(d)] > OK > OK > OK > place the pointer over the note [Fig. 16.13(e)] > move the 
pointer off of the note > LMB to deselect  
 

                                              
Figure 16.13(d) Note                                                        Figure 16.13(e) Screen Tip Displayed   
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Open the URL, click:  from the Model Tree > RMB > Open URL [Fig. 16.13(f)] (URL 
opens in the browser window) [Fig. 16.13(g)] > close the Browser > LMB to deselect > Ctrl+D > Ctrl+S > 
File > Manage File > Delete Old Versions > Enter  
 

  
Figure 16.13(f) Open URL  
 

 
Figure 16.13(g) American Precision Spring Website (this web page may have since been updated)  
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Annotation Features 
 
3D Notes can also be added to an entity using Annotation Features. Annotation features are data features that 
you can use to manage the model annotation and propagate model information to other models, or to 
manufacturing processes. The Annotation Feature Tool options correspond to the ASME Y14.41 Digital 
Product Definition Data Practices. 

An Annotation feature consists of one or more Annotation Elements. Each Annotation Element (AE) can 
contain one annotation item, along with associated references and parameters. You can include the following 
types of annotations in an Annotation Element: 
 

 Note 
 Symbol 
 Surface Finish 
 Geometric Tolerance 
 Set Datum Tag 
 Ordinate Baseline  
 Driven Dimension 
 Ordinate Driven Dimension 
 Reference Dimension 
 Ordinate Reference Dimension 
 Existing Annotation 

 

Digital Product Definition Data Practices 
 
“ASME Y14.41 establishes requirements for preparing, organizing and interpreting 3-dimensional digital 
product images (Fig. 16.14). Digital Product Definition Data Practices, which represents an extension of the 
popular Y14.5 standard for 2-dimensional drawings, reflects the growing need for a uniform method of 
documenting the data created in today’s 
computer-aided design (CAD) 
environments. The standard provides a 
guide for CAD software developers working 
on improved modeling and annotation 
practices for the engineering community. 
ASME Y14.41 sets forth the requirements 
for tolerances, dimensional data, and other 
annotations. ASME Y14.41 advances the 
capabilities of Y14.5, Dimensioning and 
Tolerancing, the standard pertaining to 2-D 
engineering drawings”. 

In the following steps you will create 
a single-view 3D definition of the model for 
manufacturing, instead of a traditional 
multi-view drawing. 
 

Figure 16.14 Digital Product Definition, ASME Y14.41 
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Click:  Open the View Manager > Orient tab > New > type Annotation > Enter > rotate the view > click 

on  > RMB > Save (Fig. 16.15) > OK (the + sign will disappear) > Close > Ctrl+S  
 

    
Figure 16.15 Reorient the Model  
 

Click:  >  > select the 3D note [Fig. 16.16(a)] > select a new note 
position [Fig. 16.16(b)] > LMB to deselect > Ctrl+S  
 

        
Figure 16.16(a) Move             Figure 16.16(b) Place the Note 
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Click:  >  > with the Annotate tab active, select the Helical Sweep 

feature > press RMB > Show Annotations [Fig. 16.17(a)] >  tab >  > OK from the Show Annotations 
dialog box [Fig. 16.17(b)] > LMB to deselect  

 

 
Figure 16.17(a) Create Driving Dimension AE 
 

 
Figure 16.17(b) Displayed Driving Dimensions 
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Select Datum_Tag_B > press RMB > Flip [Fig. 16.18(a)] > select an annotation > press and hold down the 
LMB > move the pointer to a new location > release the LMB > move each annotation to a better location > 
select the PITCH 40 annotation > press RMB > Current Orientation [Figs. 16.18(b-c)]  

 

 
Figure 16.18(a) Flip Datum_Tag_B  
 

 
Figure 16.18(b) Current Orientation (your options list may appear differently)  
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Click:  >  > TOP [Fig. 16.18(d)] > Flip > OK > move the PITCH 40 annotation as 
needed > rotate the model [Fig. 16.18(e)]  
 

              
Figure 16.18(c) Annotation Plane Dialog Box                                     Figure 16.18(d) Named Model Orientation: TOP 
 

 
Figure 16.18(e) Moved Dimensions   
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Click:  Open the View Manager > Orient tab > click on Annotation(+) > RMB > Save > OK > Close > 
Annotation tab > select the 360 dimension [Fig. 16.19(a)] > press RMB > Properties > Display tab [Fig. 
16.19(b)] > type PITCH DIAMETER > OK > LMB to deselect > Ctrl+S [Fig. 16.19(c)]  

 

 
Figure 16.19(a) Dimension Properties (your options list may appear differently)  
 

 
Figure 16.19(b) Dimension Properties Dialog Box, Display Tab (type in added text) 
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Figure 16.19(c) Annotated Part  
 

Click:  Annotation Feature >  tab [Fig. 16.20(a)]  

 

 
Figure 16.20(a) Annotation Feature Dialog Box, Geometric Tolerance   
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Click:  Parallelism [Fig. 16.20(b)] > Reference: Type:  > Surface > select the surface [Fig. 16.20(c)]  
 

 
Figure 16.20(b) Geometric Tolerance Dialog Box 
 

  
Figure 16.20(c) Select the Ground (Cut) Surface 
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Click: Placement: To Be Placed- Type  > Dimension > Place Gtol [Fig. 16.20(d)] > select the 240 dimension 

[Fig. 16.20(e)] > Datum Refs tab > Primary tab > Basic  > A [Fig. 16.20(f)] > OK  
 

 
Figure 16.20(d) Type Dimension  
 

 
Figure 16.20(e) Select the 240 Dimension 
 

 
Figure 16.20(f) Select Primary A  
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Click: OK [Fig. 16.20(g)] > Ctrl+S [Fig. 16.20(h)] > LMB to deselect  

 

 
Figure 16.20(g) Annotation Feature Dialog Box 
 

 
Figure 16.20(h) Annotation Feature Completed 
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Click:  FRONT > RMB > Set >  Annotation Feature >  Create a surface finish [Fig. 

16.21(a)] > double-click on the machined folder >  > Preview [Fig. 16.21(b)]  
 

  
Figure 16.21(a) Create a Surface Finish  
 

 
Figure 16.21(b) Preview of Surface Symbol standard1.sym  
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Click: Open [Fig. 16.21(c)] and the Surface Finish dialog box opens with its References collector active > 
select the ground surface [Fig. 16.21(d)]  

 

 
Figure 16.21(c) Surface Finish Dialog Box 
 

 
Figure 16.21(d) Reference Surface  
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Click inside the Placement collector for Attachment references [Fig. 16.21(e)] > select the symbol position on 
the cut surface [Figs. 16.21(f-g)] > MMB [Fig. 16.21(h)] 
 

 
Figure 16.21(e) Placement Collector  
 

 
Figure 16.21(f) Select the Surface Finish Symbol Position 
 

 
Figure 16.21(g) Completed Symbol Placement 
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Click: Variable Text tab > MMB > OK [Fig. 16.21(i)]  
 

 
Figure 16.21(h) General Tab Selections Completed 
 

 
Figure 16.21(i) Variable Text Tab   
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Click:  tab [Fig. 16.21(j)] > repeat the process to create an annotation feature finish symbol on the opposite 
end of the spring [Fig. 16.21(k)] > OK from the Annotation Feature dialog box > LMB to deselect 
 

 
Figure 16.21(j) Annotation Feature Dialog Box  
 

 
Figure 16.21(k) Second Surface Finish Annotation   



Creo Parametric 3.0  Lesson 16 

©	2014	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 720

 

Click: > View tab > View Manager > Orient > click on Annotations(+) > Save > OK > Close > FLAT TO 

SCREEN >  FRONT  (Fig. 16.22) >  > File > Manage File > Delete Old Versions > Enter > File 

> Save As > Type  > Zip File (*.zip) > OK > upload > File > Close > File > Exit > Yes  
 

  
Figure 16.22 Active Annotation Orientation Plane (Grid Shown in Green)  
 

Download a different spring project from www.cad-resources.com.  


